2010年01月10日

Firefox on Ubuntu [GREエラー]

昨日、Ubuntu 9.10のアップデート途中にPCがハングした。
強制終了させた後、firefoxを起動しようとしたら、
下記のようなエラーが出て起動しなくなった。

Could not find compatible GRE between version 1.9.1 and 1.9.1.*.


いろいろ調べてみると、下記のような記事が出る。
firefoxでxulrunnerのエラーがでた場合

しかし、インストールされているxulrunnerのバージョンと、/usr/lib/firefox-3.5.7/application.iniに記載されているバージョンの間に、特に不整合はない。

さらに調べてみると、下記の記事のComment #3が参考になりそう。
Bug 64 - fail to startup firefox and report "Could not find compatible GRE between version 1.9.0.2 and 1.9.0.2"

確かに、/etc/gre.d/の下が空っぽになっているので、アップデート後のxulrunnerの初期化ができてなかった模様。

そこで、
$ cd /usr/lib/firefox-3.5.7
$ sudo xulrunner ./application.ini --register-global

なおった!


#他のアップデートされたパッケージについても同じようなことが起こってそうで、何か不安だなー。
posted by kyt at 14:33| Comment(0) | TrackBack(0) | 日記 | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。
※ブログオーナーが承認したコメントのみ表示されます。
この記事へのトラックバックURL
http://blog.seesaa.jp/tb/137904532
※ブログオーナーが承認したトラックバックのみ表示されます。

この記事へのトラックバック
×

この広告は1年以上新しい記事の投稿がないブログに表示されております。